about summary refs log tree commit diff
path: root/tests/build-hook.nix
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2009-03-17T17·11+0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2009-03-17T17·11+0000
commit51e7e32c3bf7c2fb5045b0655c2edc1fbf347455 (patch)
tree21337c26d0106fa92b5f82854f623640b24dc34e /tests/build-hook.nix
parent2d5114452d8a8f73c858f9beb6bfaafe35e7bf9a (diff)
* Refactoring: renamed *.nix.in to *.nix.
Diffstat (limited to 'tests/build-hook.nix')
-rw-r--r--tests/build-hook.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/tests/build-hook.nix b/tests/build-hook.nix
new file mode 100644
index 000000000000..e4954537f393
--- /dev/null
+++ b/tests/build-hook.nix
@@ -0,0 +1,21 @@
+with import ./config.nix;
+
+let
+
+  input1 = mkDerivation {
+    name = "build-hook-input-1";
+    builder = ./dependencies.builder1.sh;
+  };
+
+  input2 = mkDerivation {
+    name = "build-hook-input-2";
+    builder = ./dependencies.builder2.sh;
+  };
+
+in
+
+  mkDerivation {
+    name = "build-hook";
+    builder = ./dependencies.builder0.sh;
+    inherit input1 input2;
+  }