about summary refs log tree commit diff
path: root/tests/binary-patching.nix
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2010-11-17T15·30+0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2010-11-17T15·30+0000
commita07c68f05edd754e389e0757ed2deefd70aad364 (patch)
tree9b4739b556517b6cf32505e2d0f888b27f104398 /tests/binary-patching.nix
parentbf658f016ff16af79535358c8e609a933b86e6d7 (diff)
* Finally, a test for the binary patch functionality.
Diffstat (limited to 'tests/binary-patching.nix')
-rw-r--r--tests/binary-patching.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/tests/binary-patching.nix b/tests/binary-patching.nix
new file mode 100644
index 000000000000..781bd76eba60
--- /dev/null
+++ b/tests/binary-patching.nix
@@ -0,0 +1,15 @@
+{ version }:
+
+with import ./config.nix;
+
+mkDerivation {
+  name = "foo-${toString version}";
+  builder = builtins.toFile "builder.sh"
+    ''
+      mkdir $out
+      seq 1 1000000 > $out/foo
+      ${if version == 2 then ''
+        echo bla >> $out/foo
+      '' else ""}
+    '';
+}