about summary refs log tree commit diff
path: root/tests/binary-patching.nix
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2010-11-17T18·01+0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2010-11-17T18·01+0000
commitd92ccbf1ac5ab68937a0e411f4daee7e427865bd (patch)
tree41f4379167678c86c8392ba154ad06691fff8110 /tests/binary-patching.nix
parent1a211d812f1808a5a9128cbfd74bb59d07487b1c (diff)
* Test whether sequences of patches work.
Diffstat (limited to 'tests/binary-patching.nix')
-rw-r--r--tests/binary-patching.nix5
1 files changed, 4 insertions, 1 deletions
diff --git a/tests/binary-patching.nix b/tests/binary-patching.nix
index afa0a0fb3f84..0de3028bd64d 100644
--- a/tests/binary-patching.nix
+++ b/tests/binary-patching.nix
@@ -8,8 +8,11 @@ mkDerivation {
     ''
       mkdir $out
       seq 1 1000000 > $out/foo
-      ${if version == 2 then ''
+      ${if version != 1 then ''
         seq 1000000 1010000 >> $out/foo
       '' else ""}
+      ${if version == 3 then ''
+        echo foobar >> $out/foo
+      '' else ""}
     '';
 }