about summary refs log tree commit diff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2004-05-11T18·05+0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2004-05-11T18·05+0000
commitc8d3882cdc8f9e22c58af285c1996265c1af75d5 (patch)
treebca454268647fa6edf6cd349fc92543b9789d188 /tests/Makefile.am
parentaea436503e9126b06cd15acf1f0c6b738ffbc7de (diff)
* True parallel builds. Nix can now run as many build jobs in
  parallel as possible (similar to GNU Make's `-j' switch).  This is
  useful on SMP systems, but it is especially useful for doing builds
  on multiple machines.  The idea is that a large derivation is
  initiated on one master machine, which then distributes
  sub-derivations to any number of slave machines.  This should not
  happen synchronously or in lock-step, so the master must be capable
  of dealing with multiple parallel build jobs.  We now have the
  infrastructure to support this.

  TODO: substitutes are currently broken.

Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am5
1 files changed, 2 insertions, 3 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index d540290b49..14662c20d4 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -17,10 +17,9 @@ dependencies.sh: dependencies.nix
 locking.sh: locking.nix
 parallel.sh: parallel.nix
 
-TESTS = init.sh simple.sh dependencies.sh parallel.sh
-#locking.sh parallel.sh
+TESTS = init.sh simple.sh dependencies.sh locking.sh parallel.sh
 
-XFAIL_TESTS = parallel.sh
+XFAIL_TESTS =
 
 include ../substitute.mk