about summary refs log tree commit diff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2004-05-04T12·15+0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2004-05-04T12·15+0000
commit256eeab7112da2d5fe1629ffb8b86640a894ee6d (patch)
treed173bcf930f86c296793a0cd20c7c83900c0bd18 /tests/Makefile.am
parentfd927c5d25f1518dcbf99a57223f46fe098d9011 (diff)
* Allow the location of the store etc. to be specified using
  environment variables.
* Started adding some automatic tests.
* Do a `make check' when building RPMs.

Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
new file mode 100644
index 0000000000..dc8c15e671
--- /dev/null
+++ b/tests/Makefile.am
@@ -0,0 +1,19 @@
+TEST_ROOT = $(shell pwd)/test-tmp
+
+TESTS_ENVIRONMENT = TEST_ROOT=$(TEST_ROOT) \
+  NIX_STORE_DIR=$(TEST_ROOT)/store \
+  NIX_DATA_DIR=$(TEST_ROOT)/data \
+  NIX_LOG_DIR=$(TEST_ROOT)/log \
+  NIX_STATE_DIR=$(TEST_ROOT)/state \
+  NIX_DB_DIR=$(TEST_ROOT)/db \
+  TOP=$(shell pwd)/.. \
+  $(SHELL) -e -x
+
+simple.sh: simple.nix
+
+TESTS = init.sh simple.sh
+
+include ../substitute.mk
+
+EXTRA_DIST = \
+  simple.nix.in simple.builder.sh