about summary refs log tree commit diff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2004-10-27T12·41+0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2004-10-27T12·41+0000
commit463e2817c55fbd5b026d7dd630541b990b82418a (patch)
treef1017907a6bee3baed04e35c5b25bdaa454dedf8 /tests/Makefile.am
parentf09618b63a3e842adc59360c9bb4cf0ad37246ef (diff)
* Remove ancient Fix tests.
* Add automated Nix expression language tests.

Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am10
1 files changed, 7 insertions, 3 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 5ac01aca3f4d..ae6da726b35a 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -11,7 +11,7 @@ TESTS_ENVIRONMENT = TEST_ROOT=$(TEST_ROOT) \
   NIX_BUILD_HOOK= \
   TOP=$(shell pwd)/.. \
   SHARED=$(extra1) \
-  $(SHELL) -e -x
+  $(SHELL) -e
 
 simple.sh: simple.nix
 dependencies.sh: dependencies.nix
@@ -22,11 +22,14 @@ substitutes.sh: substitutes.nix substituter.nix
 substitutes2.sh: substitutes2.nix substituter.nix substituter2.nix
 fallback.sh: fallback.nix
 
-TESTS = init.sh simple.sh dependencies.sh locking.sh parallel.sh \
+TESTS = init.sh lang.sh simple.sh dependencies.sh locking.sh parallel.sh \
   build-hook.sh substitutes.sh substitutes2.sh fallback.sh verify.sh
 
 XFAIL_TESTS =
 
+foo:
+	$(TESTS_ENVIRONMENT) ./lang.sh
+
 include ../substitute.mk
 
 EXTRA_DIST = $(TESTS) \
@@ -37,4 +40,5 @@ EXTRA_DIST = $(TESTS) \
   build-hook.nix.in build-hook.hook.sh \
   substitutes.nix.in substituter.nix.in substituter.builder.sh \
   substitutes2.nix.in substituter2.nix.in substituter2.builder.sh \
-  fallback.nix.in
+  fallback.nix.in \
+  $(wildcard lang/*.nix) $(wildcard lang/*.exp)