about summary refs log tree commit diff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2006-03-01T18·26+0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2006-03-01T18·26+0000
commit78d84f5631eb1d0e4b665dbaacbbb1669ba899f7 (patch)
tree2d1f8d57598b0724be689dadb83df132c98f12e6 /tests/Makefile.am
parent2167bf6b72dde2bb574ac72da0fad145504a4d3f (diff)
* Tests for fixed-output derivations (and attribute selection, incidentally).
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 3a1e07891a..9a718f1907 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -12,11 +12,12 @@ substitutes2.sh: substitutes2.nix
 fallback.sh: fallback.nix
 gc-concurrent.sh: gc-concurrent.nix gc-concurrent2.nix
 user-envs.sh: user-envs.nix
+fixed.sh: fixed.nix
 
 TESTS = init.sh hash.sh lang.sh add.sh simple.sh dependencies.sh \
   locking.sh parallel.sh build-hook.sh substitutes.sh substitutes2.sh \
   fallback.sh nix-push.sh gc.sh gc-concurrent.sh verify.sh nix-pull.sh \
-  referrers.sh user-envs.sh logging.sh nix-build.sh misc.sh
+  referrers.sh user-envs.sh logging.sh nix-build.sh misc.sh fixed.sh
 
 XFAIL_TESTS =
 
@@ -36,5 +37,6 @@ EXTRA_DIST = $(TESTS) \
   gc-concurrent2.nix.in gc-concurrent2.builder.sh \
   fallback.nix.in \
   user-envs.nix.in user-envs.builder.sh \
+  fixed.nix.in fixed.builder1.sh fixed.builder2.sh \
   $(wildcard lang/*.nix) $(wildcard lang/*.exp) \
   common.sh.in