about summary refs log tree commit diff
path: root/system/machines/bumblebee.nix
diff options
context:
space:
mode:
authorGriffin Smith <root@gws.fyi>2020-03-28T03·32-0400
committerGriffin Smith <root@gws.fyi>2020-03-28T15·47-0400
commit28ccec970435f9acfdecfae95848947c8b751e09 (patch)
tree4a55bdaab006c46cd5ad86d407d7d80fab8ed57f /system/machines/bumblebee.nix
Initial commit
It begins...
Diffstat (limited to 'system/machines/bumblebee.nix')
-rw-r--r--system/machines/bumblebee.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/system/machines/bumblebee.nix b/system/machines/bumblebee.nix
new file mode 100644
index 000000000000..a1cd3ffa143d
--- /dev/null
+++ b/system/machines/bumblebee.nix
@@ -0,0 +1,21 @@
+{ config, lib, pkgs, ... }:
+{
+  imports = [
+    ../modules/reusable/battery.nix
+  ];
+
+  networking.hostName = "bumblebee";
+
+  powerManagement = {
+    enable = true;
+    cpuFreqGovernor = "powersave";
+    powertop.enable = true;
+  };
+
+  # Hibernate on low battery
+  laptop.onLowBattery = {
+    enable = true;
+    action = "hibernate";
+    thresholdPercentage = 5;
+  };
+}