about summary refs log tree commit diff
path: root/src/nix/Makefile.am
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2003-10-20T10·05+0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2003-10-20T10·05+0000
commitc62433751d5fce8c25a802989c50fee993f39c2d (patch)
tree3be155a9a5f4e516450582c49ded9fc61173e2be /src/nix/Makefile.am
parent53e376d836133a660223198c7bb8308fb912375e (diff)
* Finished refactoring the tree.
Diffstat (limited to 'src/nix/Makefile.am')
-rw-r--r--src/nix/Makefile.am27
1 files changed, 27 insertions, 0 deletions
diff --git a/src/nix/Makefile.am b/src/nix/Makefile.am
new file mode 100644
index 0000000000..37415976b3
--- /dev/null
+++ b/src/nix/Makefile.am
@@ -0,0 +1,27 @@
+bin_PROGRAMS = nix
+
+nix_SOURCES = nix.cc dotgraph.cc
+nix_LDADD = ../libmain/libmain.a ../libnix/libnix.a ../boost/format/libformat.a \
+ -L../../externals/inst/lib -ldb_cxx -lATerm
+
+nix.o: nix-help.txt.hh
+
+%.hh: %
+	echo -n '"' > $@
+	sed 's|\(.*\)|\1\\n\\|' < $< >> $@
+	echo '"' >> $@
+
+AM_CXXFLAGS = \
+ -I.. -I../../externals/inst/include -I../libnix -I../libmain
+
+install-data-local:
+	$(INSTALL) -d $(localstatedir)/nix
+	$(INSTALL) -d $(localstatedir)/nix/db
+	$(INSTALL) -d $(localstatedir)/nix/links
+	rm -f $(prefix)/current
+	ln -sf $(localstatedir)/nix/links/current $(prefix)/current
+	$(INSTALL) -d $(localstatedir)/log/nix
+	$(INSTALL) -d $(prefix)/store
+	$(bindir)/nix --init
+
+EXTRA_DIST = *.hh