about summary refs log tree commit diff
path: root/src/nix-worker/Makefile.am
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2006-12-02T14·27+0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2006-12-02T14·27+0000
commit8ba5d32769560d32cb5e1e83fd30fb6da0b145f4 (patch)
tree5387182858fe66bba87f0f0891507fc248ccbaef /src/nix-worker/Makefile.am
parentfcd9900d74b0eb3d57402c448ede2a411133fa46 (diff)
* Remove queryPathHash().
* Help for nix-worker.

Diffstat (limited to 'src/nix-worker/Makefile.am')
-rw-r--r--src/nix-worker/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/nix-worker/Makefile.am b/src/nix-worker/Makefile.am
index 6f10efff5d57..46568e9e1bd5 100644
--- a/src/nix-worker/Makefile.am
+++ b/src/nix-worker/Makefile.am
@@ -4,6 +4,11 @@ nix_worker_SOURCES = main.cc
 nix_worker_LDADD = ../libmain/libmain.la ../libstore/libstore.la ../libutil/libutil.la \
  ../boost/format/libformat.la ${bdb_lib} ${aterm_lib}
 
+main.o: help.txt.hh
+
+%.txt.hh: %.txt
+	../bin2c/bin2c helpText < $< > $@ || (rm $@ && exit 1)
+
 AM_CXXFLAGS = \
  -I$(srcdir)/.. ${bdb_include} $(aterm_include) -I$(srcdir)/../libutil \
  -I$(srcdir)/../libstore -I$(srcdir)/../libmain