about summary refs log tree commit diff
path: root/src/nix-store/Makefile.am
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2004-02-16T15·23+0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2004-02-16T15·23+0000
commitf34de121401bb43c6cfab892b2b254e42652ba90 (patch)
tree7d421aefeabf597679a81a92139c9a338be2cfdd /src/nix-store/Makefile.am
parentfbc48a469c80201f0d159a9b9f48a22ce5f36984 (diff)
* Allow the location of the store to be specified (--with-store-dir).
* Do not create stuff in localstatedir when doing `make install'
  (since we may not have write access).  In general, installation of
  constant code/data should be separate from the initialisation of
  mutable state.

Diffstat (limited to 'src/nix-store/Makefile.am')
-rw-r--r--src/nix-store/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/nix-store/Makefile.am b/src/nix-store/Makefile.am
index 3a152e3e4b3d..76d3a6c6bedc 100644
--- a/src/nix-store/Makefile.am
+++ b/src/nix-store/Makefile.am
@@ -12,7 +12,7 @@ main.o: help.txt.hh
 AM_CXXFLAGS = \
  -I.. -I../../externals/inst/include -I../libutil -I../libstore -I../libmain
 
-install-data-local:
+init-state-local:
 	$(INSTALL) -d $(DESTDIR)$(localstatedir)/nix
 	$(INSTALL) -d $(DESTDIR)$(localstatedir)/nix/db
 	$(INSTALL) -d $(DESTDIR)$(localstatedir)/log/nix