about summary refs log tree commit diff
path: root/src/nix-hash/Makefile.am
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2003-12-01T15·55+0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2003-12-01T15·55+0000
commit078e20885e0805e04669f9b334a516a6d8d12763 (patch)
treef16741a27866a46806c99ec8d5c8371ae5298046 /src/nix-hash/Makefile.am
parent905d5b91fa6fa64e549f9019f9fab4150f00c13a (diff)
* Help text for all (non-script) programs, so no more:
$ nix-instantiate --help
error: unknown flag `--help`
Try `nix-instantiate --help' for more information.

:-)

Diffstat (limited to 'src/nix-hash/Makefile.am')
-rw-r--r--src/nix-hash/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/nix-hash/Makefile.am b/src/nix-hash/Makefile.am
index 8609cb216453..154f7a2760d2 100644
--- a/src/nix-hash/Makefile.am
+++ b/src/nix-hash/Makefile.am
@@ -4,5 +4,10 @@ nix_hash_SOURCES = nix-hash.cc
 nix_hash_LDADD = ../libmain/libmain.a ../libstore/libstore.a ../libutil/libutil.a \
  ../boost/format/libformat.a -L../../externals/inst/lib -ldb_cxx -lATerm
 
+nix-hash.o: help.txt.hh
+
+%.txt.hh: %.txt
+	../bin2c/bin2c helpText < $< > $@ || (rm $@ && exit 1)
+
 AM_CXXFLAGS = \
  -I.. -I../../externals/inst/include -I../libutil -I../libstore -I../libmain