about summary refs log tree commit diff
path: root/src/nix-env/Makefile.am
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2004-02-06T10·30+0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2004-02-06T10·30+0000
commit66e94d3275e9a0a549c28b7d0ad5f3f897e2fbf0 (patch)
tree630762722ad3a1efcf3620e905e74fea8ded5b99 /src/nix-env/Makefile.am
parentd445da7a7b3cbb4822bcad3904a36f0d914917d3 (diff)
* Improvements to profiles. Generations are now per-profile, e.g.,
  default -> default-94-link
  default-82-link -> /nix/store/cc4480...
  default-83-link -> /nix/store/caeec8...
  ...
  default-94-link -> /nix/store/2896ca...
  experimental -> experimental-2-link
  experimental-1-link -> /nix/store/cc4480...
  experimental-2-link -> /nix/store/a3148f...

* `--profile' / `-p' -> `--switch-profile' / `-S'
* `--link' / `-l' -> `--profile' / `-p'
* The default profile is stored in $prefix/var/nix/profiles.
  $prefix/var/nix/links is gone.  Profiles can be stored anywhere.
* The current profile is now referenced from ~/.nix-profile, not
  ~/.nix-userenv.
* The roots to the garbage collector now have extension `.gcroot', not
  `.id'.

Diffstat (limited to 'src/nix-env/Makefile.am')
-rw-r--r--src/nix-env/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/nix-env/Makefile.am b/src/nix-env/Makefile.am
index bfe7369c69..5353a7a6b8 100644
--- a/src/nix-env/Makefile.am
+++ b/src/nix-env/Makefile.am
@@ -14,3 +14,6 @@ main.o: help.txt.hh
 AM_CXXFLAGS = \
  -I.. -I../../externals/inst/include -I../libutil -I../libstore \
  -I../libexpr -I../libmain
+
+install-data-local:
+	$(INSTALL) -d $(DESTDIR)$(localstatedir)/nix/profiles