about summary refs log tree commit diff
path: root/src/libutil/Makefile.am
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2006-11-30T19·19+0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2006-11-30T19·19+0000
commit40b3f64b55f98e03b3173541b8d94cd924099223 (patch)
tree78a14654425eab2729e3c8077860573766a794c0 /src/libutil/Makefile.am
parent9adc074dc3e135356c2390038bf72264c29c1e03 (diff)
* Skeleton of the privileged worker program.
* Some refactoring: put the NAR archive integer/string serialisation
  code in a separate file so it can be reused by the worker protocol
  implementation.

Diffstat (limited to 'src/libutil/Makefile.am')
-rw-r--r--src/libutil/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/src/libutil/Makefile.am b/src/libutil/Makefile.am
index cf75be8a8565..bd0996543344 100644
--- a/src/libutil/Makefile.am
+++ b/src/libutil/Makefile.am
@@ -1,10 +1,12 @@
 pkglib_LTLIBRARIES = libutil.la
 
-libutil_la_SOURCES = util.cc hash.cc archive.cc aterm.cc aterm-map.cc xml-writer.cc
+libutil_la_SOURCES = util.cc hash.cc serialise.cc \
+  archive.cc aterm.cc aterm-map.cc xml-writer.cc
 
 libutil_la_LIBADD = ../boost/format/libformat.la
 
-pkginclude_HEADERS = util.hh hash.hh archive.hh aterm.hh aterm-map.hh xml-writer.hh types.hh
+pkginclude_HEADERS = util.hh hash.hh serialise.hh \
+  archive.hh aterm.hh aterm-map.hh xml-writer.hh types.hh
 
 if !HAVE_OPENSSL
 libutil_la_SOURCES += \