about summary refs log tree commit diff
path: root/src/libstore/Makefile.am
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2009-11-06T01·15+0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2009-11-06T01·15+0000
commit327a232c85de3faa56f9a6117c86e1aa22f88bd6 (patch)
treea664640621fd3d6806683e08beebc142b634b4fc /src/libstore/Makefile.am
parentc60d796f04f81b17330fbfc1e438ed207b1047f4 (diff)
* Remove support for old (before Nix 0.12pre12020) databases.
Diffstat (limited to 'src/libstore/Makefile.am')
-rw-r--r--src/libstore/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/src/libstore/Makefile.am b/src/libstore/Makefile.am
index 185bb298d701..863871519390 100644
--- a/src/libstore/Makefile.am
+++ b/src/libstore/Makefile.am
@@ -2,12 +2,12 @@ pkglib_LTLIBRARIES = libstore.la
 
 libstore_la_SOURCES = \
   store-api.cc local-store.cc remote-store.cc derivations.cc build.cc misc.cc \
-  globals.cc db.cc references.cc pathlocks.cc gc.cc upgrade-schema.cc \
+  globals.cc references.cc pathlocks.cc gc.cc \
   optimise-store.cc
 
 pkginclude_HEADERS = \
   store-api.hh local-store.hh remote-store.hh derivations.hh misc.hh \
-  globals.hh db.hh references.hh pathlocks.hh \
+  globals.hh references.hh pathlocks.hh \
   worker-protocol.hh
 
 libstore_la_LIBADD = ../libutil/libutil.la ../boost/format/libformat.la @ADDITIONAL_NETWORK_LIBS@
@@ -17,7 +17,7 @@ BUILT_SOURCES = derivations-ast.cc derivations-ast.hh
 EXTRA_DIST = derivations-ast.def derivations-ast.cc
 
 AM_CXXFLAGS = -Wall \
- -I$(srcdir)/.. ${bdb_include} ${aterm_include} -I$(srcdir)/../libutil
+ -I$(srcdir)/.. ${aterm_include} -I$(srcdir)/../libutil
 
 derivations-ast.cc derivations-ast.hh: ../aterm-helper.pl derivations-ast.def
 	$(perl) $(srcdir)/../aterm-helper.pl derivations-ast.hh derivations-ast.cc < $(srcdir)/derivations-ast.def