about summary refs log tree commit diff
path: root/src/libstore/Makefile.am
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2006-09-04T22·41+0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2006-09-04T22·41+0000
commite5a6c09b12a9a68ba604d4e95adf28482ae8fc8d (patch)
treefd119dc9b9b7fac8a91e051c9141ecdb21540f44 /src/libstore/Makefile.am
parent4be5443882cfbe7c2aa09b1c373c220400a5133f (diff)
* Install header files in /nix/include/nix.
Diffstat (limited to 'src/libstore/Makefile.am')
-rw-r--r--src/libstore/Makefile.am14
1 files changed, 8 insertions, 6 deletions
diff --git a/src/libstore/Makefile.am b/src/libstore/Makefile.am
index 3730ae5b2de1..515311efac78 100644
--- a/src/libstore/Makefile.am
+++ b/src/libstore/Makefile.am
@@ -1,12 +1,14 @@
 pkglib_LTLIBRARIES = libstore.la
 
 libstore_la_SOURCES = \
- store.cc store.hh derivations.cc derivations.hh \
- build.cc build.hh \
- misc.cc misc.hh \
- globals.cc globals.hh db.cc db.hh \
- references.cc references.hh pathlocks.cc pathlocks.hh \
- gc.cc gc.hh 
+ store.cc derivations.cc build.cc misc.cc globals.cc db.cc \
+ references.cc pathlocks.cc gc.cc 
+
+pkginclude_HEADERS = \
+ store.hh derivations.hh build.hh misc.hh globals.hh db.hh \
+ references.hh pathlocks.hh gc.hh 
+
+libstore_la_LIBADD = ../libutil/libutil.la ../boost/format/libformat.la
 
 BUILT_SOURCES = derivations-ast.cc derivations-ast.hh