about summary refs log tree commit diff
path: root/src/libmain/Makefile.am
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2012-11-27T12·29+0100
committerEelco Dolstra <eelco.dolstra@logicblox.com>2012-11-27T12·29+0100
commit8b8ee53bc73769bb25d967ba259dabc9b23e2e6f (patch)
tree79aab3b316d632fc663c1c78da25a88425f4275e /src/libmain/Makefile.am
parent5943f41b8bd95b8559cb6768bb0a1151f6bee68d (diff)
Add builtin constants ‘langVersion’ and ‘nixVersion’
The integer constant ‘langVersion’ denotes the current language
version.  It gets increased every time a language feature is
added/changed/removed.  It's currently 1.

The string constant ‘nixVersion’ contains the current Nix version,
e.g. "1.2pre2980_9de6bc5".
Diffstat (limited to 'src/libmain/Makefile.am')
-rw-r--r--src/libmain/Makefile.am1
1 files changed, 0 insertions, 1 deletions
diff --git a/src/libmain/Makefile.am b/src/libmain/Makefile.am
index 404353c62922..6a2d7f5f58e5 100644
--- a/src/libmain/Makefile.am
+++ b/src/libmain/Makefile.am
@@ -7,6 +7,5 @@ libmain_la_LIBADD = ../libstore/libstore.la @BDW_GC_LIBS@
 pkginclude_HEADERS = shared.hh
 
 AM_CXXFLAGS = \
- -DNIX_VERSION=\"$(VERSION)\" \
  -I$(srcdir)/.. -I$(srcdir)/../libutil \
  -I$(srcdir)/../libstore