about summary refs log tree commit diff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2004-09-09T15·55+0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2004-09-09T15·55+0000
commit5396304c73190c6898981caf653fc1b28be71f70 (patch)
tree3c028375474b943d91e505f5b853fc8abdaa8a02 /src/Makefile.am
parente043fc7d0b68bedaabe236c2f2080a33bb967ee5 (diff)
* Use setre[ug]id() instead of setres[ug]id(), since the former is
  more common than the latter (which exists only on Linux and
  FreeBSD).  We don't really care about dropping the saved IDs since
  there apparently is no way to quiry them in any case, so it can't
  influence the build (unlike the effective IDs which are checked by
  Perl for instance).

Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 5637382172a2..b7eb905f9273 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -4,7 +4,7 @@ SUBDIRS = bin2c boost libutil libstore libmain nix-store nix-hash \
 SETUID_PROGS = nix-store nix-instantiate nix-env
 install-exec-hook:
 if SETUID_HACK
-if HAVE_SETRESUID
+if HAVE_SETREUID
 	cd $(DESTDIR)$(bindir) && chown @NIX_USER@ $(SETUID_PROGS) \
 	  && chgrp @NIX_GROUP@ $(SETUID_PROGS) && chmod ug+s $(SETUID_PROGS)
 else