about summary refs log tree commit diff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2006-11-29T21·06+0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2006-11-29T21·06+0000
commit71e867c5f5ee2c188244da33366e506935abffb7 (patch)
tree9ebf9f95e1af9f70f368a721ad1fb43493a75be2 /src/Makefile.am
parentc6a97e3b74289fdc8e57189212a0db3d0e6896e0 (diff)
* Remove --enable-setuid, --with-nix-user and --with-nix-group.
  Rather, setuid support is now always compiled in (at least on
  platforms that have the setresuid system call, e.g., Linux and
  FreeBSD), but it must enabled by chowning/chmodding the Nix
  binaries.

Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am11
1 files changed, 1 insertions, 10 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 1cdbc558ae..2bf789fd3b 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -3,13 +3,4 @@ SUBDIRS = bin2c boost libutil libstore libmain nix-store nix-hash \
 
 EXTRA_DIST = aterm-helper.pl
 
-SETUID_PROGS = nix-store nix-instantiate nix-env
-install-exec-hook:
-if SETUID_HACK
-if HAVE_SETRESUID
-	cd $(DESTDIR)$(bindir) && chown @NIX_USER@ $(SETUID_PROGS) \
-	  && chgrp @NIX_GROUP@ $(SETUID_PROGS) && chmod ug+s $(SETUID_PROGS)
-else
-	cd $(DESTDIR)$(bindir) && chown root $(SETUID_PROGS) && chmod u+s $(SETUID_PROGS)
-endif
-endif
+#SETUID_PROGS = nix-store nix-instantiate nix-env