about summary refs log tree commit diff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2003-08-01T14·11+0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2003-08-01T14·11+0000
commit545145cd582cd80b857760ec11bb5a91b6271506 (patch)
treee992edea7a634ed268ac10444add5dcfac6a4f05 /src/Makefile.am
parent9df93f30bda81ffa3cf040c146347e02d3a56666 (diff)
* normaliseFState() now locks all output paths prior to building, thus
  ensuring that simultaneous invocations of Nix don't clobber
  each other's  builds.

* Fixed a bug in `make install'.

Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 847f3eb19f..85bf502825 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -22,7 +22,7 @@ noinst_LIBRARIES = libnix.a libshared.a
 
 libnix_a_SOURCES = util.cc hash.cc archive.cc md5.c \
  store.cc fstate.cc normalise.cc exec.cc \
- globals.cc db.cc references.cc
+ globals.cc db.cc references.cc pathlocks.cc
 
 libshared_a_SOURCES = shared.cc
 
@@ -44,6 +44,7 @@ install-data-local:
 	$(INSTALL) -d $(localstatedir)/nix
 	$(INSTALL) -d $(localstatedir)/nix/db
 	$(INSTALL) -d $(localstatedir)/nix/links
+	rm -f $(prefix)/current
 	ln -sf $(localstatedir)/nix/links/current $(prefix)/current
 	$(INSTALL) -d $(localstatedir)/log/nix
 	$(INSTALL) -d $(prefix)/store