about summary refs log tree commit diff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2003-07-23T15·53+0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2003-07-23T15·53+0000
commit39ce70025b59a545127d1ffdefa83b7cbfcd8be1 (patch)
tree073ced88097af91b11f9331168d823a7fff8d64f /src/Makefile.am
parent9202570f8c40f58f6444c2ec512104b305058977 (diff)
* Incorporated Berkeley DB and ATerm into the source tree.
* `make dist'.

Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index eb5177d13e..98d76b7536 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,7 +1,8 @@
 bin_PROGRAMS = nix nix-hash fix
 check_PROGRAMS = test
 
-AM_CXXFLAGS = -DSYSTEM=\"@host@\" -Wall -I..
+AM_CXXFLAGS = -DSYSTEM=\"@host@\" -Wall -I.. -I../externals/inst/include $(CXXFLAGS)
+AM_LDFLAGS = -L../externals/inst/lib -ldb_cxx -lATerm $(LDFLAGS)
 
 nix_SOURCES = nix.cc
 nix_LDADD = libshared.a libnix.a -ldb_cxx -lATerm
@@ -29,7 +30,8 @@ libshared_a_CXXFLAGS = \
  -DNIX_STORE_DIR=\"$(prefix)/store\" \
  -DNIX_DATA_DIR=\"$(datadir)\" \
  -DNIX_STATE_DIR=\"$(localstatedir)/nix\" \
- -DNIX_LOG_DIR=\"$(localstatedir)/log/nix\"
+ -DNIX_LOG_DIR=\"$(localstatedir)/log/nix\" \
+ $(AM_CXXFLAGS)
 
 install-data-local:
 	$(INSTALL) -d $(localstatedir)/nix
@@ -37,3 +39,5 @@ install-data-local:
 	$(INSTALL) -d $(localstatedir)/log/nix
 	$(INSTALL) -d $(prefix)/store
 	$(bindir)/nix --init
+
+EXTRA_DIST = *.hh *.h
\ No newline at end of file