about summary refs log tree commit diff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2003-09-11T10·23+0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2003-09-11T10·23+0000
commit1c7d6bf5fcddae13b6226d61fe60cfccb8d2c359 (patch)
tree777ecaa6e71cd874243d6661a6b698715c4062d0 /src/Makefile.am
parentd930a9bc5a69b33dc7fe707838ccdd72e89f8079 (diff)
* Removed references to char_traits so that boost/format also works on
  GCC 2.95.

Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am12
1 files changed, 7 insertions, 5 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index cddcae1c66..a422fb8cff 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,22 +1,24 @@
 bin_PROGRAMS = nix nix-hash fix
 check_PROGRAMS = test
 
+
 AM_CXXFLAGS = -DSYSTEM=\"@host@\" -Wall -I.. -I../externals/inst/include $(CXXFLAGS)
-AM_LDFLAGS = -L../externals/inst/lib -ldb_cxx -lATerm $(LDFLAGS)
+LDADD = -L../externals/inst/lib -ldb_cxx -lATerm -L../boost/format -lformat
 
 nix_SOURCES = nix.cc dotgraph.cc
-nix_LDADD = libshared.a libnix.a -ldb_cxx -lATerm
+nix_LDADD = libshared.a libnix.a $(LDADD)
 
 nix_hash_SOURCES = nix-hash.cc
-nix_hash_LDADD = libshared.a libnix.a -ldb_cxx -lATerm
+nix_hash_LDADD = libshared.a libnix.a $(LDADD)
 
 fix_SOURCES = fix.cc
-fix_LDADD = libshared.a libnix.a -ldb_cxx -lATerm
+fix_LDADD = libshared.a libnix.a $(LDADD)
 
 TESTS = test
 
 test_SOURCES = test.cc
-test_LDADD = libshared.a libnix.a -ldb_cxx -lATerm
+test_LDADD = libshared.a libnix.a $(LDADD)
+
 
 noinst_LIBRARIES = libnix.a libshared.a