about summary refs log tree commit diff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2003-06-16T13·33+0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2003-06-16T13·33+0000
commit822794001cb4260b8c04a7bd2d50d890edae709a (patch)
treec4c3a86f638422c8d756752050ebcbb45eba2ee7 /src/Makefile.am
parentb9f09b3268bf0c3d9ecd512dd3a0aa1247550cc2 (diff)
* Started implementing the new evaluation model.
* Lots of refactorings.
* Unit tests.

Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am13
1 files changed, 6 insertions, 7 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index a56a0ae0e8..80d9e4af8d 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -9,16 +9,15 @@ nix_LDADD = -ldb_cxx-4 -lATerm
 fix_SOURCES = fix.cc util.cc hash.cc md5.c
 fix_LDADD = -lATerm
 
-test_SOURCES = test.cc util.cc hash.cc md5.c
+test_SOURCES = test.cc util.cc hash.cc md5.c eval.cc values.cc globals.cc db.cc
+test_LDADD = -ldb_cxx-4 -lATerm
 
 install-data-local:
 	$(INSTALL) -d $(localstatedir)/nix
-	$(INSTALL) -d $(localstatedir)/nix/descriptors
-	$(INSTALL) -d $(localstatedir)/nix/sources
 	$(INSTALL) -d $(localstatedir)/nix/links
-	$(INSTALL) -d $(localstatedir)/nix/prebuilts
-	$(INSTALL) -d $(localstatedir)/nix/prebuilts/imports
-	$(INSTALL) -d $(localstatedir)/nix/prebuilts/exports
+#	$(INSTALL) -d $(localstatedir)/nix/prebuilts
+#	$(INSTALL) -d $(localstatedir)/nix/prebuilts/imports
+#	$(INSTALL) -d $(localstatedir)/nix/prebuilts/exports
 	$(INSTALL) -d $(localstatedir)/log/nix
-	$(INSTALL) -d $(prefix)/pkg
+	$(INSTALL) -d $(prefix)/values
 	$(bindir)/nix init