about summary refs log tree commit diff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2003-04-06T22·19+0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2003-04-06T22·19+0000
commit814b256da43ebdad79fe9544a59f6ae680da7cb9 (patch)
treec38a8d3d378e9efd0fc44cb0158a322c6ba104fe /src/Makefile.am
parent2eea8832f0bc5f15979b5f091c3ac5f04593f0ca (diff)
* Better installation: make directories, create database.
* Fixed the register script.

Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 17d801fbf3..e1db3c4ebe 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -3,3 +3,10 @@ bin_PROGRAMS = nix
 nix_SOURCES = nix.cc md5.c
 nix_CXXFLAGS = -DSYSTEM=\"@host@\"
 nix_LDADD = -ldb_cxx-4 -lATerm
+
+install-data-local:
+	$(INSTALL) -d $(localstatedir)/nix
+	$(INSTALL) -d $(localstatedir)/nix/descriptors
+	$(INSTALL) -d $(localstatedir)/nix/sources
+	$(INSTALL) -d $(prefix)/pkg
+	$(bindir)/nix init