about summary refs log tree commit diff
path: root/shell.nix
diff options
context:
space:
mode:
authorEelco Dolstra <edolstra@gmail.com>2017-11-01T15·32+0100
committerEelco Dolstra <edolstra@gmail.com>2017-11-01T16·45+0100
commit1969f357b7f9abbff82b613b88ae53b84ff4e483 (patch)
treec9adfde5a45ee8bfc65b56f3a065798e30f1ebcc /shell.nix
parentcd532a92510fdc895d45bb768b036921b4a26282 (diff)
Add fetchMercurial primop
E.g.

  $ nix eval '(fetchMercurial https://www.mercurial-scm.org/repo/hello)'
  { branch = "default"; outPath = "/nix/store/alvb9y1kfz42bjishqmyy3pphnrh1pfa-source"; rev = "82e55d328c8ca4ee16520036c0aaace03a5beb65"; revCount = 1; shortRev = "82e55d328c8c"; }

  $ nix eval '(fetchMercurial { url = https://www.mercurial-scm.org/repo/hello; rev = "0a04b987be5ae354b710cefeba0e2d9de7ad41a9"; })'
  { branch = "default"; outPath = "/nix/store/alvb9y1kfz42bjishqmyy3pphnrh1pfa-source"; rev = "0a04b987be5ae354b710cefeba0e2d9de7ad41a9"; revCount = 0; shortRev = "0a04b987be5a"; }

  $ nix eval '(fetchMercurial /tmp/unclean-hg-tree)'
  { branch = "default"; outPath = "/nix/store/cm750cdw1x8wfpm3jq7mz09r30l9r024-source"; rev = "0000000000000000000000000000000000000000"; revCount = 0; shortRev = "000000000000"; }
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix3
1 files changed, 3 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
index 2b4d0dd201..02fbd59b12 100644
--- a/shell.nix
+++ b/shell.nix
@@ -23,6 +23,9 @@ with import ./release-common.nix { inherit pkgs; };
       # For nix-perl
       perl
       perlPackages.DBDSQLite
+
+      # Tests
+      mercurial
     ]
     ++ lib.optional stdenv.isLinux libseccomp;