about summary refs log tree commit diff
path: root/shell.nix
diff options
context:
space:
mode:
authorEelco Dolstra <edolstra@gmail.com>2018-03-14T18·01+0100
committerEelco Dolstra <edolstra@gmail.com>2018-03-14T18·24+0100
commitca14b142001ab467e679d4ed0cc6236180bf34b2 (patch)
treeb7d89f1b6703eea64dc3aa9e6f2f354c3cd9f0c3 /shell.nix
parent56f2ed00813f49e2834076787f98438a976eebb1 (diff)
Use boost::format from the boost package
Note that this only requires headers from boost so it doesn't add a
runtime dependency.

Also, use Nixpkgs 18.03.
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/shell.nix b/shell.nix
index d6ae5a55226e..09318dfd0782 100644
--- a/shell.nix
+++ b/shell.nix
@@ -1,6 +1,6 @@
 { useClang ? false }:
 
-with import <nixpkgs> {};
+with import (builtins.fetchGit { url = https://github.com/NixOS/nixpkgs.git; ref = "release-18.03"; }) {};
 
 with import ./release-common.nix { inherit pkgs; };
 
@@ -18,6 +18,7 @@ with import ./release-common.nix { inherit pkgs; };
         customMemoryManagement = false;
       })
       autoreconfHook
+      boost
 
       # For nix-perl
       perl