about summary refs log tree commit diff
path: root/shell.nix
diff options
context:
space:
mode:
authorWilliam Carroll <wpcarro@gmail.com>2020-07-28T11·49+0100
committerWilliam Carroll <wpcarro@gmail.com>2020-07-28T11·51+0100
commitb170be937532cf976746a50f26b05ff34c4c9c00 (patch)
tree3230276044f02c87d14642ec6636d653e40104b1 /shell.nix
parentbb36dd1f9e7dfaa806fbda1317b9e53aed49b4ea (diff)
Hash passwords when creating accounts
TL;DR:
- introduce the Cryptonite library
- Remove the redundant language extensions, imports, deps from Persistent
- Prefer NoContent return type for POST /accounts
- Define custom {To,From}JSON instances for Role
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix4
1 files changed, 1 insertions, 3 deletions
diff --git a/shell.nix b/shell.nix
index 3312fef13d00..e003737f3b2e 100644
--- a/shell.nix
+++ b/shell.nix
@@ -8,9 +8,7 @@ in pkgs.mkShell {
       hpkgs.resource-pool
       hpkgs.sqlite-simple
       hpkgs.warp
-      hpkgs.persistent
-      hpkgs.persistent-sqlite
-      hpkgs.persistent-template
+      hpkgs.cryptonite
     ]))
   ];
 }