about summary refs log tree commit diff
path: root/shell.nix
diff options
context:
space:
mode:
authorWilliam Carroll <wpcarro@gmail.com>2020-07-24T17·59+0100
committerWilliam Carroll <wpcarro@gmail.com>2020-07-24T17·59+0100
commitec90748b827edcd465020acd5bd23ae6a01ba37a (patch)
treee65c166e6386d09271a0192d8ea15917eb07465d /shell.nix
parent26271ec178f4edd1bf02b4697fed611915ebc698 (diff)
Create a shell.nix
Manage the project's dependencies using Nix.
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix8
1 files changed, 8 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 000000000000..3a5a4ef9ecc5
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,8 @@
+let
+  pkgs = import <nixpkgs> {};
+in pkgs.mkShell {
+  buildInputs = with pkgs; [
+    (haskellPackages.ghcWithPackages (hpkgs: with hpkgs; [
+    ]))
+  ];
+}