about summary refs log tree commit diff
path: root/shell.nix
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2019-11-18T15·29+0100
committerFlorian Klink <flokli@flokli.de>2019-11-18T15·29+0100
commitdbd7b4807a6364630d43edf309eb4b43f4bb3658 (patch)
tree6150837d72f22232bdf123acd55edc34b9c1f47c /shell.nix
parent987b539e335ebc93eba9549ebf8204d612b7a148 (diff)
use statik to bundle assets, add nix-shell/lorri .envrc
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix11
1 files changed, 11 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 000000000000..b28839aa28c8
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,11 @@
+let
+  pkgs = (import (builtins.fetchTarball {
+    url = "https://github.com/NixOS/nixpkgs/archive/5de728659b412bcf7d18316a4b71d9a6e447f460.tar.gz";
+    sha256 = "1bdykda8k8gl2vcp36g27xf3437ig098yrhjp0hclv7sn6dp2w1l";
+  })) {};
+in
+  pkgs.mkShell {
+    buildInputs = [
+        pkgs.statik
+    ];
+  }