about summary refs log tree commit diff
path: root/shell.nix
diff options
context:
space:
mode:
authorWilliam Carroll <wpcarro@gmail.com>2020-07-24T18·00+0100
committerWilliam Carroll <wpcarro@gmail.com>2020-07-24T18·00+0100
commit660b8d43e5272e2b71b6092b4c879a82c4d861a8 (patch)
tree08e2be141393a591349618d7b8a426887f79ae21 /shell.nix
parentec90748b827edcd465020acd5bd23ae6a01ba37a (diff)
Support a basic API
Use Servant to create a REST API supporting the following routes:
- GET /number
- POST /other

The server interacts with a SQLite database.
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix5
1 files changed, 5 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
index 3a5a4ef9ecc5..96c18c8e9f90 100644
--- a/shell.nix
+++ b/shell.nix
@@ -3,6 +3,11 @@ let
 in pkgs.mkShell {
   buildInputs = with pkgs; [
     (haskellPackages.ghcWithPackages (hpkgs: with hpkgs; [
+      hpkgs.servant-server
+      hpkgs.aeson
+      hpkgs.resource-pool
+      hpkgs.sqlite-simple
+      hpkgs.warp
     ]))
   ];
 }