about summary refs log tree commit diff
path: root/shell.nix
diff options
context:
space:
mode:
authorWilliam Carroll <wpcarro@gmail.com>2020-07-30T16·05+0100
committerWilliam Carroll <wpcarro@gmail.com>2020-07-30T16·07+0100
commit30838b8df7350d9dd37b5873f21247d6bddefc15 (patch)
treebbe0dc380d36c3d056ca4d640c05b97d369cb4fa /shell.nix
parentb6e8389edd486d407025383825a1beaf6b7f63b7 (diff)
Add Haskell client library for MailGun
Whichever package is on nixpkgs right now is broken, so I'm using `fetchGit` and
`callCabal2nix`.

Create Email module exposing a simplifies `send` function that partially applies
some of the configuration options.
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix6
1 files changed, 6 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
index bd31438b1957..811061186e2e 100644
--- a/shell.nix
+++ b/shell.nix
@@ -1,5 +1,10 @@
 let
   pkgs = import <nixpkgs> {};
+  hailgun-src = builtins.fetchGit {
+    url = "https://bitbucket.org/echo_rm/hailgun.git";
+    rev = "9d5da7c902b2399e0fcf3d494ee04cf2bbfe7c9e";
+  };
+  hailgun = pkgs.haskellPackages.callCabal2nix "hailgun" hailgun-src {};
 in pkgs.mkShell {
   buildInputs = with pkgs; [
     (haskellPackages.ghcWithPackages (hpkgs: with hpkgs; [
@@ -11,6 +16,7 @@ in pkgs.mkShell {
       hpkgs.cryptonite
       hpkgs.uuid
       hpkgs.envy
+      hailgun
     ]))
   ];
 }