about summary refs log tree commit diff
path: root/shell.nix
diff options
context:
space:
mode:
authorEelco Dolstra <edolstra@gmail.com>2018-03-14T18·11+0100
committerEelco Dolstra <edolstra@gmail.com>2018-03-14T18·25+0100
commitc04bca34016c41d1fcab222e2d61a26a285340c6 (patch)
treee1323fa3c0755065656a8e6c33edb8785950718d /shell.nix
parentca14b142001ab467e679d4ed0cc6236180bf34b2 (diff)
Factor out commonality between release.nix and shell.nix
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix23
1 files changed, 1 insertions, 22 deletions
diff --git a/shell.nix b/shell.nix
index 09318dfd07..20cf4133b3 100644
--- a/shell.nix
+++ b/shell.nix
@@ -7,28 +7,7 @@ with import ./release-common.nix { inherit pkgs; };
 (if useClang then clangStdenv else stdenv).mkDerivation {
   name = "nix";
 
-  buildInputs =
-    [ curl bison flex libxml2 libxslt
-      bzip2 xz brotli
-      pkgconfig sqlite libsodium boehmgc
-      docbook5 docbook5_xsl
-      autoconf-archive
-      (aws-sdk-cpp.override {
-        apis = ["s3"];
-        customMemoryManagement = false;
-      })
-      autoreconfHook
-      boost
-
-      # For nix-perl
-      perl
-      perlPackages.DBDSQLite
-
-      # Tests
-      git
-      mercurial
-    ]
-    ++ lib.optional stdenv.isLinux libseccomp;
+  buildInputs = buildDeps ++ tarballDeps ++ perlDeps;
 
   inherit configureFlags;