about summary refs log tree commit diff
path: root/shell.nix
diff options
context:
space:
mode:
authorWilliam Carroll <wpcarro@gmail.com>2020-07-30T12·58+0100
committerWilliam Carroll <wpcarro@gmail.com>2020-07-30T12·58+0100
commitb6e8389edd486d407025383825a1beaf6b7f63b7 (patch)
treeb38c6fd1231bce0548be7557f2e509cea84b66c1 /shell.nix
parent385164c6afea7995b797cf8ddddefa187c26f646 (diff)
Read env variables using envy library
Using my dear friend's, dmjio's, excellent library, envy -- to read and parse
variables from the system environment.

I added and git-ignored the .envrc file that contains API secrets. I'm using
Envy to read these values, so that I don't hard-code these values into the
source code.
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix1
1 files changed, 1 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
index 8c948e9cb55d..bd31438b1957 100644
--- a/shell.nix
+++ b/shell.nix
@@ -10,6 +10,7 @@ in pkgs.mkShell {
       hpkgs.warp
       hpkgs.cryptonite
       hpkgs.uuid
+      hpkgs.envy
     ]))
   ];
 }