about summary refs log tree commit diff
path: root/shell.nix
diff options
context:
space:
mode:
authorEelco Dolstra <edolstra@gmail.com>2016-11-28T15·13+0100
committerEelco Dolstra <edolstra@gmail.com>2016-12-06T16·17+0100
commit09191caea8a0bf59daef553ca251a8d1d7e1d507 (patch)
tree87cb608cb13d4fdb53ea262988724685fd338501 /shell.nix
parentd1da6967b8891763ce04d668027cf300c9bbf0b2 (diff)
Add shell.nix
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix33
1 files changed, 33 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 0000000000..272627692a
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,33 @@
+with import <nixpkgs> {};
+
+stdenv.mkDerivation {
+  name = "nix";
+
+  buildInputs =
+    [ curl bison flex perl libxml2 libxslt bzip2 xz
+      pkgconfig sqlite libsodium boehmgc
+      docbook5 docbook5_xsl
+      autoconf-archive
+      (aws-sdk-cpp.override {
+        apis = ["s3"];
+        customMemoryManagement = false;
+      })
+      autoreconfHook
+    ];
+
+  configureFlags =
+    [ "--disable-init-state"
+      "--enable-gc"
+      "--with-dbi=${perlPackages.DBI}/${perl.libPrefix}"
+      "--with-dbd-sqlite=${perlPackages.DBDSQLite}/${perl.libPrefix}"
+    ];
+
+  enableParallelBuilding = true;
+
+  installFlags = "sysconfdir=$(out)/etc";
+
+  shellHook =
+    ''
+      configureFlags+=" --prefix=$(pwd)/inst"
+    '';
+}