about summary refs log tree commit diff
path: root/shell.nix
diff options
context:
space:
mode:
authorGriffin Smith <root@gws.fyi>2019-08-31T17·15-0400
committerGriffin Smith <root@gws.fyi>2019-08-31T17·15-0400
commit6eba471e2426e7e4e7d5c935e3ce973e13fd6b24 (patch)
treee7b41534bdd6b08fcd8c0e1c5444f3605e66cf09 /shell.nix
parentd3f3890dc5408581eb6181125c871d1cf2c0e18f (diff)
Use haskellSrc2nix over explicit cabal2nix
Use the (undocumented!) helper function haskellSrc2nix over having to
explicitly run cabal2nix all the time when rebuilding
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/shell.nix b/shell.nix
index aefc492d3d..966ab0bb08 100644
--- a/shell.nix
+++ b/shell.nix
@@ -1,8 +1,8 @@
-{ nixpkgs ? import <nixpkgs> {}, compiler ? "ghc865", withHoogle ? true }:
+{ nixpkgs ? import ./nixpkgs.nix {}, compiler ? "ghc865", withHoogle ? true }:
 let
   inherit (nixpkgs) pkgs;
 
-  xan = import ./xanthous.nix;
+  pkg = import ./pkg.nix { inherit nixpkgs; };
 
   packageSet = (
     if compiler == "default"
@@ -21,7 +21,7 @@ let
     else packageSet
   );
 
-  drv = haskellPackages.callPackage xan {};
+  drv = haskellPackages.callPackage pkg {};
 
   inherit (pkgs.haskell.lib) addBuildTools;
 in