about summary refs log tree commit diff
path: root/setup.py
diff options
context:
space:
mode:
authormajuss <biomajuss@gmail.com>2020-04-10T07·23+0200
committerGitHub <noreply@github.com>2020-04-10T07·23+0200
commita6827caaf7d796145649d3de69ee5e5bb2f43e66 (patch)
treec0411795ac7beda5dc2d837fdd70f374e71b52e6 /setup.py
parent2bc7b06c69487b7750792e1f913905aecd46da3c (diff)
Removed PyCRC as dependency; implemented CRC16 directly (#327)
* Removed PyCRC as dependency; implemented CRC16 directly

* replace crc16 with integrated function

* Added self to calculate crc
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 6183611ded..b7fe6b6f22 100644
--- a/setup.py
+++ b/setup.py
@@ -15,7 +15,7 @@ setup(
     url='http://github.com/mjg59/python-broadlink',
     packages=find_packages(),
     scripts=[],
-    install_requires=['cryptography>=2.1.1', 'PyCRC'],
+    install_requires=['cryptography>=2.1.1'],
     description='Python API for controlling Broadlink IR controllers',
     classifiers=[
         'Development Status :: 4 - Beta',