about summary refs log tree commit diff
path: root/setup.py
diff options
context:
space:
mode:
authorMatthew Garrett <mjg59@coreos.com>2016-09-15T15·06-0700
committerMatthew Garrett <mjg59@coreos.com>2016-09-15T20·20-0700
commitecab016a73eee8d018a4b8617eb2c2680dbc284d (patch)
tree51ad30152afdee37b73389b4d6d64af0d326dc0b /setup.py
Initial commit
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py32
1 files changed, 32 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 000000000000..4ac0917f38bb
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,32 @@
+#!/usr/bin/env python
+# -*- coding: utf-8 -*-
+
+import re
+from setuptools import setup, find_packages
+import sys
+import warnings
+
+dynamic_requires = []
+
+version = 0.1
+
+setup(
+    name='broadlink',
+    version=0.1,
+    author='Matthew Garrett',
+    author_email='mjg59@srcf.ucam.org',
+    url='http://github.com/mjg59/python-broadlink',
+    packages=find_packages(),
+    scripts=[],
+    license=open('LICENSE').read(),
+    description='Python API for controlling Broadlink IR controllers',
+    classifiers=[
+        'Development Status :: 4 - Beta',
+        'Intended Audience :: Developers',
+        'License :: OSI Approved :: MIT License',
+        'Operating System :: OS Independent',
+        'Programming Language :: Python',
+    ],
+    include_package_data=True,
+    zip_safe=False,
+)