about summary refs log tree commit diff
path: root/setup.py
diff options
context:
space:
mode:
authorDaniel Høyer Iversen <mail@dahoiv.net>2019-10-02T06·25+0300
committerGitHub <noreply@github.com>2019-10-02T06·25+0300
commit2e5361bd8ee470b35884538914a2e3bc579ec1c5 (patch)
treeb5c4e48b082741c47aa98fda0c7e008d84a9fcc4 /setup.py
parent11c5981793f4a9b23ebceaf0ac2efdd74187c192 (diff)
Remove support for pyaes (#281)
* remove support for pyaes

* remove support for pyaes

* remove support for pyaes
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py13
1 files changed, 1 insertions, 12 deletions
diff --git a/setup.py b/setup.py
index bc6495797bdf..ca48ea29b33c 100644
--- a/setup.py
+++ b/setup.py
@@ -1,20 +1,9 @@
 #!/usr/bin/env python
 # -*- coding: utf-8 -*-
 
-import re
-import sys
-import warnings
 
 from setuptools import setup, find_packages
 
-try:
-    import cryptography
-    dynamic_requires = ['cryptography>=2.1.1']
-except ImportError:
-    dynamic_requires = ["pyaes==1.6.0"]
-
-# For Hysen thermostatic heating controller
-dynamic_requires.append('PyCRC')
 
 version = '0.11.1'
 
@@ -26,7 +15,7 @@ setup(
     url='http://github.com/mjg59/python-broadlink',
     packages=find_packages(),
     scripts=[],
-    install_requires=dynamic_requires,
+    install_requires=['cryptography>=2.1.1', 'PyCRC'],
     description='Python API for controlling Broadlink IR controllers',
     classifiers=[
         'Development Status :: 4 - Beta',