summary refs log tree commit diff
path: root/services/tazblog/tazblog.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@google.com>2019-08-19T23·17+0100
committerVincent Ambo <tazjin@google.com>2019-08-19T23·17+0100
commit11fcf6229751eb266485cbba78d30aced1787d14 (patch)
tree025f02ca1d1288949f69468e32d9efe795db02a7 /services/tazblog/tazblog.nix
parent1d5b53abf8da7b00ac1e58d43a30f738c157b9d3 (diff)
chore(tazblog): Replace BlogDB with stubs for DNS-based storage r/44
Removes acid-state specific code and the former BlogDB module, in its
stead the new BlogStorage module contains stubs for the functions that
will be filled in with DNS-based storage.

This code is unformatted and will not currently serve a working blog.
Diffstat (limited to '')
-rw-r--r--services/tazblog/tazblog.nix12
1 files changed, 6 insertions, 6 deletions
diff --git a/services/tazblog/tazblog.nix b/services/tazblog/tazblog.nix
index 1b65384fa6..cb62383826 100644
--- a/services/tazblog/tazblog.nix
+++ b/services/tazblog/tazblog.nix
@@ -6,17 +6,17 @@
 }:
 mkDerivation {
   pname = "tazblog";
-  version = "5.1.3";
+  version = "6.0.0";
   src = ./.;
   isLibrary = true;
   isExecutable = true;
   libraryHaskellDepends = [
-    acid-state base base64-bytestring blaze-html blaze-markup
-    bytestring crypto-api cryptohash hamlet happstack-server ixset
-    markdown mtl network network-uri old-locale rss safecopy
-    shakespeare text time transformers
+    base base64-bytestring blaze-html blaze-markup bytestring
+    crypto-api cryptohash hamlet happstack-server markdown mtl
+    network network-uri old-locale rss shakespeare text time
+    transformers
   ];
-  executableHaskellDepends = [ acid-state base network options ];
+  executableHaskellDepends = [ base network options ];
   description = "Tazjin's Blog";
   license = stdenv.lib.licenses.mit;
 }