about summary refs log tree commit diff
path: root/services/sync-gcsr/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@google.com>2019-12-20T13·16+0000
committerVincent Ambo <tazjin@google.com>2019-12-20T13·16+0000
commit7078bc7a4a2134bb12002144f660f4dbdcbf838d (patch)
tree176e55fa92261f437c02bbae20e4a0093461c6c3 /services/sync-gcsr/default.nix
parent43ceaa17e35eac0101a3628143f6b58b67c9067a (diff)
feat(services/sync-gcsr): Add git synchronisation helper r/211
Adds a tiny program that keeps a checkout of a remote git repository
in sync with a folder on the local filesystem.

This is going to be used to mirror the GCSR repository onto a local
disk for cgit serving.
Diffstat (limited to 'services/sync-gcsr/default.nix')
-rw-r--r--services/sync-gcsr/default.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/services/sync-gcsr/default.nix b/services/sync-gcsr/default.nix
new file mode 100644
index 000000000000..114ff221bed1
--- /dev/null
+++ b/services/sync-gcsr/default.nix
@@ -0,0 +1,10 @@
+{ pkgs, ... }:
+
+pkgs.buildGo.program {
+  name = "sync-gcsr";
+  srcs = [ ./main.go ];
+
+  deps = with pkgs.third_party; map (p: p.gopkg) [
+    gopkgs."gopkg.in".src-d.go-git
+  ];
+}