about summary refs log tree commit diff
path: root/services/gemma/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@google.com>2019-11-15T15·26+0000
committerVincent Ambo <tazjin@google.com>2019-11-15T15·26+0000
commitc1c379848a19a31de8febb1385c7b9e4d2a474a3 (patch)
treef019521edfb4590b6c59d84e77c422a21671ca89 /services/gemma/default.nix
parent4d852e2ef73a0901a3426ae5ab93232b6a0a8ed2 (diff)
chore(nix): Move files around to conform to new read-tree layout
Broadly speaking, the following things are included:

* there is now a uniform `args` struct that is passed to all
  derivations, package headers have been changed appropriately
* overrides are now loaded from a separate `override` folder just
  using read-tree.nix
* third-party packages have moved into the `third_party` attribute set
Diffstat (limited to 'services/gemma/default.nix')
-rw-r--r--services/gemma/default.nix31
1 files changed, 17 insertions, 14 deletions
diff --git a/services/gemma/default.nix b/services/gemma/default.nix
index 409d8eef38..ea10a4c7d0 100644
--- a/services/gemma/default.nix
+++ b/services/gemma/default.nix
@@ -1,17 +1,20 @@
-{ stdenv, sbcl, lispPackages, elmPackages, makeWrapper, openssl }:
-
-let frontend = stdenv.mkDerivation {
-  name = "gemma-frontend";
-  src = ./frontend;
-  buildInputs = [ elmPackages.elm ];
-
-  phases = [ "unpackPhase" "buildPhase" ];
-  buildPhase = ''
-    mkdir .home && export HOME="$PWD/.home"
-    mkdir -p $out
-    elm-make --yes Main.elm --output $out/index.html
-  '';
-};
+{ pkgs, ... }:
+
+let
+  inherit (pkgs) stdenv sbcl lispPackages elmPackages makeWrapper openssl;
+
+  frontend = stdenv.mkDerivation {
+    name = "gemma-frontend";
+    src = ./frontend;
+    buildInputs = [ elmPackages.elm ];
+
+    phases = [ "unpackPhase" "buildPhase" ];
+    buildPhase = ''
+      mkdir .home && export HOME="$PWD/.home"
+      mkdir -p $out
+      elm-make --yes Main.elm --output $out/index.html
+    '';
+  };
 in stdenv.mkDerivation rec {
   name = "gemma";
   src = ./.;