about summary refs log tree commit diff
path: root/services/cgit-taz/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@google.com>2019-12-20T17·28+0000
committerVincent Ambo <tazjin@google.com>2019-12-20T17·28+0000
commitde309848eb49a13018a0f62195f9dc74801ef0ec (patch)
treef4109b3a9a4e4b28665c8db57660a9b45a6312e1 /services/cgit-taz/default.nix
parentb1be226626fc00f698565b64694a66de9b404877 (diff)
feat(cgit-taz): Patch cgit to construct monorepo URLs r/224
Effectively dropping /depot/ from all URLs.
Diffstat (limited to '')
-rw-r--r--services/cgit-taz/default.nix9
1 files changed, 8 insertions, 1 deletions
diff --git a/services/cgit-taz/default.nix b/services/cgit-taz/default.nix
index e59d076a2a..79cf579ec1 100644
--- a/services/cgit-taz/default.nix
+++ b/services/cgit-taz/default.nix
@@ -22,9 +22,16 @@ let
     repo.owner=tazjin <tazjin@google.com>
     repo.clone-url=https://git.tazj.in ssh://source.developers.google.com:2022/p/tazjins-infrastructure/r/depot
   '';
+
+  # Patched version of cgit that builds repository URLs correctly
+  # (since only one repository is served)
+  monocgit = cgit.overrideAttrs(old: {
+    patches = old.patches ++ [ ./cgit_depot_url.patch ];
+  });
+
   thttpdConfig = writeText "thttpd.conf" ''
     port=8080
-    dir=${cgit}/cgit
+    dir=${monocgit}/cgit
     nochroot
     novhost
     logfile=/dev/stdout