about summary refs log tree commit diff
path: root/services/cgit-taz/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@google.com>2019-12-18T16·22+0000
committerVincent Ambo <tazjin@google.com>2019-12-18T16·22+0000
commit11022c1b88c4546fb000de2e1ac42066f63009d2 (patch)
tree38d763464afa6f030f800edad1c396a7b673e6ef /services/cgit-taz/default.nix
parenta40c2474fef27fd0e482f10e95a9ad02dabcb97c (diff)
feat(services/cgit-taz): Check in initial cgit configuration r/180
This is currently just a test to serve examples from my local machine,
nothing more fancy than that.
Diffstat (limited to 'services/cgit-taz/default.nix')
-rw-r--r--services/cgit-taz/default.nix51
1 files changed, 51 insertions, 0 deletions
diff --git a/services/cgit-taz/default.nix b/services/cgit-taz/default.nix
new file mode 100644
index 0000000000..c815d90d38
--- /dev/null
+++ b/services/cgit-taz/default.nix
@@ -0,0 +1,51 @@
+# This derivation configures a 'cgit' instance to serve repositories
+# from a different source.
+#
+# In the first round this will just serve my GitHub repositories until
+# I'm happy with the display.
+
+{ pkgs, ... }:
+
+with pkgs.third_party;
+
+let
+  cgitConfig = writeText "cgitrc" ''
+    virtual-root=/cgit.cgi/
+
+    repo.url=depot
+    repo.path=/home/tazjin/depot/.git
+    repo.desc=tazjin's personal monorepo
+  '';
+  cgitPatch = writeText "cgit_config.patch" ''
+    diff --git a/Makefile b/Makefile
+    index 05ea71f..0df886e 100644
+    --- a/Makefile
+    +++ b/Makefile
+    @@ -4,7 +4,7 @@ CGIT_VERSION = v1.2.1
+     CGIT_SCRIPT_NAME = cgit.cgi
+     CGIT_SCRIPT_PATH = /var/www/htdocs/cgit
+     CGIT_DATA_PATH = $(CGIT_SCRIPT_PATH)
+    -CGIT_CONFIG = /etc/cgitrc
+    +CGIT_CONFIG = ${cgitConfig}
+     CACHE_ROOT = /var/cache/cgit
+     prefix = /usr/local
+     libdir = $(prefix)/lib
+  '';
+  cgitWithConfig = cgit.overrideAttrs(old: {
+    patches = old.patches ++ [ cgitPatch ];
+  });
+  thttpdConfig = writeText "thttpd.conf" ''
+    port=8080
+    dir=${cgitWithConfig}/cgit
+    nochroot
+    novhost
+    logfile=/dev/stdout
+    cgipat=**.cgi
+  '';
+  # Patched version of thttpd that serves cgit.cgi as the index
+  thttpdCgit = thttpd.overrideAttrs(old: {
+    patches = [ ./cgit_idx.patch ];
+  });
+in writeShellScriptBin "cgit-launch" ''
+  exec ${thttpdCgit}/bin/thttpd -D -C ${thttpdConfig}
+# ''