about summary refs log tree commit diff
path: root/services/cgit-taz/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@google.com>2019-12-20T20·18+0000
committerVincent Ambo <tazjin@google.com>2019-12-20T20·18+0000
commit03bfe08e1dd9faf48b06cb146bfa446575cde88a (patch)
tree55317968922a9b2a01516f1b79527874df037517 /services/cgit-taz/default.nix
parente52eed3cd4f73779c2e7c350537fb346835ba9f3 (diff)
chore: Significantly restructure folder layout r/237
This moves the various projects from "type-based" folders (such as
"services" or "tools") into more appropriate semantic folders (such as
"nix", "ops" or "web").

Deprecated projects (nixcon-demo & gotest) which only existed for
testing/demonstration purposes have been removed.

(Note: *all* builds are broken with this commit)
Diffstat (limited to 'services/cgit-taz/default.nix')
-rw-r--r--services/cgit-taz/default.nix69
1 files changed, 0 insertions, 69 deletions
diff --git a/services/cgit-taz/default.nix b/services/cgit-taz/default.nix
deleted file mode 100644
index 4559eb4dbf..0000000000
--- a/services/cgit-taz/default.nix
+++ /dev/null
@@ -1,69 +0,0 @@
-# This derivation configures a 'cgit' instance to serve repositories
-# from a different source.
-#
-# In the first round this will just serve my GitHub repositories until
-# I'm happy with the display.
-
-{ pkgs, ... }:
-
-with pkgs.third_party;
-
-let
-  # Patched version of cgit that builds repository URLs correctly
-  # (since only one repository is served)
-  monocgit = cgit.overrideAttrs(old: {
-    patches = old.patches ++ [ ./cgit_depot_url.patch ];
-  });
-
-  cgitConfig = writeText "cgitrc" ''
-    # Global configuration
-    virtual-root=/
-    enable-http-clone=1
-    readme=:README.md
-    about-filter=${monocgit}/lib/cgit/filters/about-formatting.sh
-    source-filter=${monocgit}/lib//cgit/filters/syntax-highlighting.py
-
-    # Repository configuration
-    repo.url=depot
-    repo.path=/git/depot/.git
-    repo.desc=tazjin's personal monorepo
-    repo.owner=tazjin <mail@tazj.in>
-    repo.clone-url=https://git.tazj.in ssh://source.developers.google.com:2022/p/tazjins-infrastructure/r/depot
-    repo.enable-remote-branches=1
-  '';
-
-  thttpdConfig = writeText "thttpd.conf" ''
-    port=8080
-    dir=${monocgit}/cgit
-    nochroot
-    novhost
-    logfile=/dev/stdout
-    cgipat=**.cgi
-  '';
-
-  # Patched version of thttpd that serves cgit.cgi as the index and
-  # sets the environment variable for pointing cgit at the correct
-  # configuration.
-  #
-  # Things are done this way because recompilation of thttpd is much
-  # faster than cgit and I don't want to wait long when iterating on
-  # config.
-  thttpdConfigPatch = writeText "thttpd_cgit_conf.patch" ''
-    diff --git a/libhttpd.c b/libhttpd.c
-    index c6b1622..eef4b73 100644
-    --- a/libhttpd.c
-    +++ b/libhttpd.c
-    @@ -3055,4 +3055,6 @@ make_envp( httpd_conn* hc )
-
-         envn = 0;
-    +    // force cgit to load the correct configuration
-    +    envp[envn++] = "CGIT_CONFIG=${cgitConfig}";
-         envp[envn++] = build_env( "PATH=%s", CGI_PATH );
-     #ifdef CGI_LD_LIBRARY_PATH
-  '';
-  thttpdCgit = thttpd.overrideAttrs(old: {
-    patches = [ ./cgit_idx.patch thttpdConfigPatch ];
-  });
-in writeShellScriptBin "cgit-launch" ''
-  exec ${thttpdCgit}/bin/thttpd -D -C ${thttpdConfig}
-# ''