about summary refs log tree commit diff
path: root/scripts/Makefile.am
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2008-07-18T13·05+0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2008-07-18T13·05+0000
commit8bc591a6f07ee577b5aa594dfa705f3ddabd269d (patch)
tree674f4cfa3ee0c43d38881a16f729bd863f2f3b17 /scripts/Makefile.am
parent15f39aba8ceb2dabc4f019bd1c985ca9d13bfdb4 (diff)
* Use the copy-from-other-stores substituter by default. Of course,
  it only does something if $NIX_OTHER_STORES (not really a good
  name...) is set.
* Do globbing on the elements of $NIX_OTHER_STORES.  E.g. you could
  set it to /mnts/*/nix or something.
* Install substituters in libexec/nix/substituters.

Diffstat (limited to 'scripts/Makefile.am')
-rw-r--r--scripts/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/scripts/Makefile.am b/scripts/Makefile.am
index 6a6226ebe73b..d6af9806cee4 100644
--- a/scripts/Makefile.am
+++ b/scripts/Makefile.am
@@ -15,10 +15,12 @@ install-exec-local: readmanifest.pm download-using-manifests.pl copy-from-other-
 	$(INSTALL) -d $(DESTDIR)$(libexecdir)/nix
 	$(INSTALL_DATA) readmanifest.pm $(DESTDIR)$(libexecdir)/nix 
 	$(INSTALL_DATA) readconfig.pm $(DESTDIR)$(libexecdir)/nix 
-	$(INSTALL_PROGRAM) download-using-manifests.pl $(DESTDIR)$(libexecdir)/nix 
 	$(INSTALL_PROGRAM) find-runtime-roots.pl $(DESTDIR)$(libexecdir)/nix 
 	$(INSTALL_PROGRAM) generate-patches.pl $(DESTDIR)$(libexecdir)/nix 
 	$(INSTALL_PROGRAM) build-remote.pl $(DESTDIR)$(libexecdir)/nix 
+	$(INSTALL) -d $(DESTDIR)$(libexecdir)/nix/substituters
+	$(INSTALL_PROGRAM) download-using-manifests.pl $(DESTDIR)$(libexecdir)/nix/substituters
+	$(INSTALL_PROGRAM) copy-from-other-stores.pl $(DESTDIR)$(libexecdir)/nix/substituters
 	$(INSTALL) -d $(DESTDIR)$(sysconfdir)/nix
 
 include ../substitute.mk