about summary refs log tree commit diff
path: root/scripts/Makefile.am
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2008-07-12T18·58+0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2008-07-12T18·58+0000
commit15f39aba8ceb2dabc4f019bd1c985ca9d13bfdb4 (patch)
treedd3a35ea37ca84ec5c978f3ecd661ad66dab6edf /scripts/Makefile.am
parent7cd88b1dec29f33188e789d780ec2e4ebb155d20 (diff)
* Quick prototype of a substituter that copies paths from other Nix
  stores (typically remote Nix stores mounted via e.g. NFS, or the Nix
  store on the NixOS installation CD).  Example use:

  $ sshfs foo@example.org:/ /mnt
  $ NIX_OTHER_STORES=/mnt/nix \
    NIX_SUBSTITUTERS=.../copy-from-other-stores.pl \
    nix-env -i foo

  This will be especially useful for the installation CD since it
  doesn't require a manifest for the CD contents.

Diffstat (limited to 'scripts/Makefile.am')
-rw-r--r--scripts/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/scripts/Makefile.am b/scripts/Makefile.am
index fa66e58949dc..6a6226ebe73b 100644
--- a/scripts/Makefile.am
+++ b/scripts/Makefile.am
@@ -9,7 +9,7 @@ noinst_SCRIPTS = nix-profile.sh generate-patches.pl \
 
 nix-pull nix-push: readmanifest.pm readconfig.pm download-using-manifests.pl
 
-install-exec-local: readmanifest.pm download-using-manifests.pl find-runtime-roots.pl
+install-exec-local: readmanifest.pm download-using-manifests.pl copy-from-other-stores.pl find-runtime-roots.pl
 	$(INSTALL) -d $(DESTDIR)$(sysconfdir)/profile.d
 	$(INSTALL_PROGRAM) nix-profile.sh $(DESTDIR)$(sysconfdir)/profile.d/nix.sh
 	$(INSTALL) -d $(DESTDIR)$(libexecdir)/nix
@@ -31,6 +31,7 @@ EXTRA_DIST = nix-collect-garbage.in \
   readconfig.pm.in \
   nix-build.in \
   download-using-manifests.pl.in \
+  copy-from-other-stores.pl.in \
   generate-patches.pl.in \
   nix-pack-closure.in nix-unpack-closure.in \
   nix-copy-closure.in \