about summary refs log tree commit diff
path: root/scripts/Makefile.am
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2003-04-09T12·26+0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2003-04-09T12·26+0000
commitaa8fda4b54fbd84b7bc6b11904c156367683e8f6 (patch)
tree736e0545b69f5062be1d8bb366bd0617e8469911 /scripts/Makefile.am
parentf56b7312b273546871a1eca7d34c60474d3c4050 (diff)
* We no longer use nix-populate standalone, rather we use it as a
  build action for `system' packages (like system.fix) that have
  dependencies on all packages we want to activate.

  So the command sequence to switch to a new activation configuration
  of the system would be:

    $ fix -i .../fixdescriptors/system.fix
    ...
    system.fix -> 89cf4713b37cc66989304abeb9ea189f

    $ nix-switch 89cf4713b37cc66989304abeb9ea189f

* A nix-profile.sh script that can be included in .bashrc.

Diffstat (limited to 'scripts/Makefile.am')
-rw-r--r--scripts/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/scripts/Makefile.am b/scripts/Makefile.am
new file mode 100644
index 000000000000..4e2eada86b9d
--- /dev/null
+++ b/scripts/Makefile.am
@@ -0,0 +1,5 @@
+bin_SCRIPTS = nix-generate-regscript nix-switch
+
+install-exec-local:
+	$(INSTALL) -d $(sysconfdir)/profile.d
+	$(INSTALL_PROGRAM) nix-profile.sh $(sysconfdir)/profile.d/nix.sh