about summary refs log tree commit diff
path: root/scripts/Makefile.am
diff options
context:
space:
mode:
authorMichael Raskin <7c6f434c@mail.ru>2008-02-27T21·26+0000
committerMichael Raskin <7c6f434c@mail.ru>2008-02-27T21·26+0000
commit11d512e7a812e750deccf616b461876fb0a342c2 (patch)
tree4ae3cf7008df48569ff597e6fbe177b118f0669d /scripts/Makefile.am
parent0a84137c4512e0a31802e94de7795e04f8ee2198 (diff)
Added nix-reduce-build. You point it to some path you want to build and it fetches whatever it can from specified computers via nix-copy-closure. NOTE: You do want to set up RSA keys or ssh-agent or something... You really do want it. It will run separate ssh instances insane number of times.
Diffstat (limited to 'scripts/Makefile.am')
-rw-r--r--scripts/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/scripts/Makefile.am b/scripts/Makefile.am
index e79db31b7c22..50975ab274b1 100644
--- a/scripts/Makefile.am
+++ b/scripts/Makefile.am
@@ -2,7 +2,7 @@ bin_SCRIPTS = nix-collect-garbage \
   nix-pull nix-push nix-prefetch-url \
   nix-install-package nix-channel nix-build \
   nix-pack-closure nix-unpack-closure \
-  nix-copy-closure
+  nix-copy-closure nix-reduce-build
 
 noinst_SCRIPTS = nix-profile.sh generate-patches.pl \
   find-runtime-roots.pl build-remote.pl
@@ -35,4 +35,5 @@ EXTRA_DIST = nix-collect-garbage.in \
   nix-pack-closure.in nix-unpack-closure.in \
   nix-copy-closure.in \
   find-runtime-roots.pl.in \
-  build-remote.pl.in
+  build-remote.pl.in \
+  nix-reduce-build.in