about summary refs log tree commit diff
path: root/scripts/Makefile.am
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2006-05-31T09·24+0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2006-05-31T09·24+0000
commit04cf72287bc27e4eca69d527ce44a88b7fcbebb2 (patch)
tree8495a2eee3ac5167b82a88e68cca8ba8ff7ef316 /scripts/Makefile.am
parent1390ce4142d511b284b354f984d84fdb12ae850b (diff)
* This may be useful in the future.
Diffstat (limited to 'scripts/Makefile.am')
-rw-r--r--scripts/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/scripts/Makefile.am b/scripts/Makefile.am
index 428d3fa6985a..bffbdbde5ddd 100644
--- a/scripts/Makefile.am
+++ b/scripts/Makefile.am
@@ -5,13 +5,14 @@ bin_SCRIPTS = nix-collect-garbage \
 
 noinst_SCRIPTS = nix-profile.sh generate-patches.pl
 
-nix-pull nix-push: readmanifest.pm download-using-manifests.pl
+nix-pull nix-push: readmanifest.pm readconfig.pm download-using-manifests.pl
 
 install-exec-local: readmanifest.pm download-using-manifests.pl
 	$(INSTALL) -d $(DESTDIR)$(sysconfdir)/profile.d
 	$(INSTALL_PROGRAM) nix-profile.sh $(DESTDIR)$(sysconfdir)/profile.d/nix.sh
 	$(INSTALL) -d $(DESTDIR)$(libexecdir)/nix
 	$(INSTALL_DATA) readmanifest.pm $(DESTDIR)$(libexecdir)/nix 
+	$(INSTALL_DATA) readconfig.pm $(DESTDIR)$(libexecdir)/nix 
 	$(INSTALL_PROGRAM) download-using-manifests.pl $(DESTDIR)$(libexecdir)/nix 
 	$(INSTALL) -d $(DESTDIR)$(sysconfdir)/nix
 
@@ -22,6 +23,7 @@ EXTRA_DIST = nix-collect-garbage.in \
   nix-prefetch-url.in nix-install-package.in \
   nix-channel.in \
   readmanifest.pm.in \
+  readconfig.pm.in \
   nix-build.in \
   download-using-manifests.pl.in \
   generate-patches.pl.in \