about summary refs log tree commit diff
path: root/scripts/Makefile.am
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2007-02-21T23·14+0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2007-02-21T23·14+0000
commit024a8ed3822867c5f9b9498bd8b27fa5dc180846 (patch)
tree55bfadfddb5a36f4cf30e5dff755bb572a3d6149 /scripts/Makefile.am
parent7f6161ab3af81e0adf834d9cfb6d232ad5c54ec2 (diff)
* New command `nix-copy-closure' to copy a closure to a Nix store on
  another machine through ssh.  E.g.,

    $ nix-copy-closure xyzzy $(which svn)

  copies the closure of Subversion to machine `xyzzy'.  This is like
  `nix-pack-closure $(which svn) | ssh xyzzy', but it's much more
  efficient since it only copies those paths that are missing on the
  target machine.

Diffstat (limited to 'scripts/Makefile.am')
-rw-r--r--scripts/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/scripts/Makefile.am b/scripts/Makefile.am
index 2c27f832eda9..e16b36d6112f 100644
--- a/scripts/Makefile.am
+++ b/scripts/Makefile.am
@@ -1,7 +1,8 @@
 bin_SCRIPTS = nix-collect-garbage \
   nix-pull nix-push nix-prefetch-url \
   nix-install-package nix-channel nix-build \
-  nix-pack-closure nix-unpack-closure
+  nix-pack-closure nix-unpack-closure \
+  nix-copy-closure
 
 noinst_SCRIPTS = nix-profile.sh generate-patches.pl find-runtime-roots.pl
 
@@ -30,4 +31,5 @@ EXTRA_DIST = nix-collect-garbage.in \
   download-using-manifests.pl.in \
   generate-patches.pl.in \
   nix-pack-closure.in nix-unpack-closure.in \
+  nix-copy-closure.in \
   find-runtime-roots.pl.in